Server Requirements

  • PHP 7.2
    • OpenSSL PHP Extension
    • PDO PHP Extension
    • Mbstring PHP Extension
    • Tokenizer PHP Extension
    • XML PHP Extension
    • Ctype PHP Extension
    • JSON PHP Extension
    • ImageMagick PHP Extension
  • MySQL 5.7
  • Node JS (8.9.4) – this is only required for compiling SCSS to CSS
  • Git
  • ImageMagick
  • Nginx

Although MarketplaceKit has been tested on Ubuntu 16.04 LTS. It should work with any OS that satisfies the above requirements. Nginx is recommended as a webserver. Developers wanting to implement their own changes should also have knowledge of Laravel, Bootstrap and Twig for extending/building on top of MarketplaceKit.